<!DOCTYPE html>
<html>
  <head>



                  


 
     


		
  




<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="HandheldFriendly" content="True">
<meta name="MobileOptimized" content="320">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="robots" content="NOODP">
<meta name="description" content="HOUSTON &mdash; The Houston Texans wanted to honour their late owner and founder Robert &quot;Bob&quot; McNair, who died last week at age 81.They knew the perfect way to do that Monday night was to keep their . . ." /> <meta name="news_keywords" content="General news, Professional football, Football, NFL football, Athlete injuries, Athlete health, Record setting events, Sports, sport"/>
<meta name="title" content="Texans beat Titans 34-17 for team-record 8th straight win">
<meta name="DC.title" content="Texans beat Titans 34-17 for team-record 8th straight win"><meta name="author" content="Kristie Rieken">
<meta name="DC.creator" content="Kristie Rieken"><meta name="keywords" content="General news, Professional football, Football, NFL football, Athlete injuries, Athlete health, Record setting events, Sports, sport">
<meta name="DC.subject" content="General news, Professional football, Football, NFL football, Athlete injuries, Athlete health, Record setting events, Sports, sport"> <meta itemprop="inLanguage" content="en">
    <meta itemprop="identifier" content="1.23510412">
    <meta itemprop="pageType" content="article">   
    <meta itemprop="expires" content="2019-02-25T04:33Z" />     <meta itemprop="image"  content="https://images.glaciermedia.ca/polopoly_fs/1.23510428.1543302619!/fileImage/httpImage/image.jpg_gen/derivatives/box_397/txeg118-1127-2018-003553-jpg.jpg" />    <meta itemprop="magnet:custom" name="section" content="Sports">
    <meta itemprop="articleSection" content="Sports">

<!-- gmg.HTMLHEADFacebookOGMetaTags.vm -->


              
    <meta property="og:type" content="article" />
    
    
    <meta property="fb:app_id" content="250236318489841" />
        
   	    
    <meta property="og:site_name" content="Prince George Citizen"/>
        
    
    <meta property="og:url" content="https://www.princegeorgecitizen.com/texans-beat-titans-34-17-for-team-record-8th-straight-win-1.23510412"/>
        
    
    <meta property="og:title" content="Texans beat Titans 34-17 for team-record 8th straight win">
        
    
    <meta property="og:image" content="https://images.glaciermedia.ca/polopoly_fs/1.23510428.1543302619!/fileImage/httpImage/image.jpg_gen/derivatives/facebookogimage_560_292/txeg118-1127-2018-003553-jpg.jpg" />
    <meta property="og:image:width" content="560" />
    <meta property="og:image:height" content="292" />
        
    
    <meta property="og:description" content="HOUSTON — The Houston Texans wanted to honour their late owner and founder Robert &#34;Bob&#34; McNair, who died last week at age 81.They knew the perfect way to do that Monday night was to keep their . . .">
    
<meta property="article:section" content="Sports" /><meta property="article:publisher" content="https://www.facebook.com/pgcitizen" /> <meta name="twitter:site" content="@pgcitizen"/><meta name="twitter:title" content="Texans beat Titans 34-17 for team-record 8th straight win">	<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="https://images.glaciermedia.ca/polopoly_fs/1.23510428.1543302619!/fileImage/httpImage/image.jpg_gen/derivatives/facebookogimage_560_292/txeg118-1127-2018-003553-jpg.jpg" /><meta name="twitter:description" content="HOUSTON — The Houston Texans wanted to honour their late owner and founder Robert &#34;Bob&#34; McNair, who died last week at age 81.They knew the perfect way to do that Monday night was to keep their . . .">

	<meta name="msvalidate.01" content="9CCB455B7FDA1B44FB0E618929FC0140" />


<link rel="canonical"  itemprop="url" href="https://www.princegeorgecitizen.com/texans-beat-titans-34-17-for-team-record-8th-straight-win-1.23510412" />
<link rel="schema.DC" href="https://www.purl.org/dc/elements/1.1/">

		   <link href="/gmg/v2/theme-news1/css/entry_article_standard.min.css?zz=4292" media="all" rel="stylesheet" type="text/css" />
	


<link rel="apple-touch-icon" href="/gmg/img/apple/PRINCEGEORGE_touch-icon-iphone.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/gmg/img/apple/PRINCEGEORGE_touch-icon-ipad.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/gmg/img/apple/PRINCEGEORGE_touch-icon-iphone-retina.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/gmg/img/apple/PRINCEGEORGE_touch-icon-ipad-retina.png" />

      
    <script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=5be326518509a10011c44813&product=custom-share-buttons" ></script>
        
        
 <link rel="shortcut icon" type="image/x-icon" href="/polopoly_fs/1.6264155.1483565410!/fileImage/httpImage/favicon.png" />
      
        
    <script type="text/javascript" src="//cdn.districtm.ca/merge/all.glacier.js" ></script>
    
			<script src="/gmg/v2/theme-news1/js/entry_article_standard.min.js?zz=4282" type="text/javascript"></script>
	




<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>



<!-- Promoted Content Widget Head Code -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/glaciermedia-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>

<script>
	var gmgAdUnit = {
		tcSiteName: '',
		section: '',
		targetParams: '',
		adRenderingSync:''
	}
	try {
		gmgAdUnit.section = 'homepage';
		gmgAdUnit.targetParams =  'nk=print;site=PRINCEGEORGE;publisher=GNG-BC;section=homepage;$subsections;keywords=General news, Professional football, Football, NFL football, Athlete injuries, Athlete health, Record setting events, Sports, sport;';
		gmgAdunit.sync = 'false'
	} catch(e) {
		//something went wrong. Ad params not set. 
	}
	
</script>
<!-- Variables for video preroll targetting -->
<script>
	
	var subFull = '$subsections';
	var subStripped = subFull.replace('subsection=','');
	
	var gmgPreRollVars = {
		site:'PRINCEGEORGE',
		publisher:'GNG-BC',
		section:'homepage',
		subsection:subStripped
	}
	</script>

<script>
var gmgSite = {
	layoutTheme: "default-news",
	unminify:  					false, 
					autohideTiles: false
}
</script>

<script>
dataLayer = [{
			'hasImages': 'TRUE',
	    	'authorName': 'Kristie Rieken',
            	'sourceSite': 'Canadian Press',
        'canonicalSection': 'sports',
    'canonicalSubSection':'',
 'siteName': 'Prince George Citizen',
 'userAgent': navigator.userAgent
}];
</script>
<script>
    GMGTheme = {
        name: 'none'
    };
            GMGTheme.name = 'theme-def';
    </script>


    
<script type="text/javascript">
  <!--
  jQuery(document).ready(function() {
      window.pageLoaded=true
  });
  //-->
</script>



<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script>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</script>
<script>
 
 gmgArticleAdunit = {
 	section: 'homepage',
 	subsection: ''
 }

</script>    

      

       
<title>Texans beat Titans 34-17 for team-record 8th straight win</title> 
</head>
<body class="theme-2 ad-wallpaper2 respad theme-def pgc yes-rightrail right-rightrail mobile-header-v2 flex-ads-v2 content-article ua-mobile ua-android-phone section-sports">

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TZGGN6"
		height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-TZGGN6');</script>
	
	
			<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s);js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12&appId=250236318489841&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>	<div itemscope itemtype="http://schema.org/Article" id="container" class="container KFC">
<!-- #container div start -->

<section class="masthead container-fluid">
    
                  
    
  
    
  
    
    
        <nav class="fixed-top bg-white">
	<div class="container">
									






  
  
      <div class="mdl-nav-block-flex position-relative">
  	
                                                    <a href="https://www.princegeorgecitizen.com/" title="Prince George Citizen" class="d-flex align-items-center justify-content-center py-1 mr-2" target="_parent">
            <div class="w-100">
              <img src="/gmg/img/logos/PGCLogo.png" alt="Prince George Citizen" class="my-0 mx-auto"/>
            </div>
          </a>
                    	
        
      
      <div class="d-flex mdl-ul-parent single-item-menu">

        <a class="searchbutton ml-2"><i class="fa fa-search"></i></a>

        <ul class="top-navigation d-flex flex-row align-content-center my-0 ml-0">
        
        
          
          
        
          
                      




      <li class='nav-item dropdown mainmenu-link d-flex align-items-center'>
      
      <a href='Javascript:void(0)' class='main-nav-link text-uppercase opensans dropdown-close' id='menu-link'><span class="fa fa-bars"></span> <span class="desktop-item">Menu</span></a>
    </li>
  



          
                
        </ul>
        
        
          
                    
            <div class="align-items-center social-media-bar d-none d-sm-flex">
  <div class="icon fb"><a href="https://www.facebook.com/pgcitizen" target="_blank" title="follow us on facebook">&#xf082;</a></div>
  <div class="icon tw"><a href="https://twitter.com/pgcitizen" target="_blank" title="follow us on twitter">&#xf081;</a></div>
  <div class="icon inst"><a href="https://www.instagram.com/princegeorgecitizen/" target="_blank" title="follow us on instagram">&#xf16d;</a></div>
  <div class="icon sub"><a href="http://www.princegeorgecitizen.com/newsletter/subscribe" target="_blank" title="subscribe to our newsletter">&#xf14b;</a></div>
  <div class="icon con"><a href="http://www.princegeorgecitizen.com/contact-us" title="contact us">&#xf199;</a></div>
</div>          
          
        
          
          
        
      </div>

  	
        
                  
    
  
    
  
    
    
        





              
                  
           
                    <form action="/search-results-7.10685" method="get" id="search" class="form-inline search-form">
              <div class="form-group-wrapper">
          <label for="q" class="font-weight-bold d-none d-md-block">Search:</label>
          <div class="icon-addon">
              <input class="form-control search-element" type="text" name="q" value="" placeholder="Search the Prince George Citizen" autocomplete="off"  size="32">
              <i class="fa fa-search"></i>
          </div>
        </div>
      </form>
      
      
  
          </div>
  						</div>
</nav>
      
  
      
<div class="dropdown-menu-new">
      <ul class="d-flex flex-wrap flex-nav">
      <li class="dropit-trigger submenu-collapsed"><a class="c-menu-close">Close <i></i></a></li>
    </ul>    
    
                  
    
  
    
  
    
    
        	







      <ul class="d-flex flex-wrap flex-nav">
                                                 
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed">
          
                    <a class="" href="/results" title="Results" >Results</a>
                    
                              </li>

                                           
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed toggle">
          
                    <a class="" href="/news" title="News" >News</a>
                    
                                <ul class="hidden dropit-submenu">
                    
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/news/local-news" title="Local News">Local News</a>
                                  </li>
                            
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/news/bc-news" title="BC News">BC News</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/news/national-news" title="National News">National News</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/news/world" title="World">World</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/news/royal-wedding" title="Royal Wedding">Royal Wedding</a>
                                  </li>
                      
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/news/business" title="Business">Business</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/news/author-bios" title="Author bios">Author bios</a>
                                  </li>
       
            </ul>
                    </li>

                                                                         
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed toggle">
          
                    <a class="" href="/opinion" title="Opinion" >Opinion</a>
                    
                                <ul class="hidden dropit-submenu">
                    
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/opinion/editorial" title="Editorial">Editorial</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/opinion/columnists" title="Columnists">Columnists</a>
                                  </li>
                
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/opinion/letters" title="Letters">Letters</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/opinion/send-us-a-letter" title="Send us a letter">Send us a letter</a>
                                  </li>
       
            </ul>
                    </li>

                                           
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed toggle">
          
                    <a class="" href="/sports" title="Sports" >Sports</a>
                    
                                <ul class="hidden dropit-submenu">
                          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/sports/hockey" title="Hockey">Hockey</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/sports/national" title="National">National</a>
                                  </li>
                                                                                           
            </ul>
                    </li>

                                                          
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed toggle">
          
                    <a class="" href="/entertainment" title="Entertainment" >Entertainment</a>
                    
                                <ul class="hidden dropit-submenu">
                    
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/entertainment/local-a-e" title="Local A & E">Local A & E</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/entertainment/events" title="Events">Events</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/entertainment/submit-event" title="Submit Event">Submit Event</a>
                                  </li>
                
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/entertainment/kid-scoop" title="Kid Scoop">Kid Scoop</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/entertainment/links" title="Links">Links</a>
                                  </li>
                
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/entertainment/horoscopes" title="Horoscopes">Horoscopes</a>
                                  </li>
                                     
            </ul>
                    </li>

                                           
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed">
          
                    <a class="" href="/washington-post" title="Washington Post" >Washington Post</a>
                    
                              </li>

                                           
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed">
          
                    <a class="" href="/real-estate" title="Real Estate" >Real Estate</a>
                    
                              </li>

                                           
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed">
          
                    <a class="" href="/standout" title="Standout" >Standout</a>
                    
                              </li>

                                           
                    
                              
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed">
          
                    <a class="" href="https://issuu.com/pgcitizen/docs/profiles-2017-online" title="Profiles of Excellence" target='_blank'>Profiles of Excellence</a>
                    
                              </li>

                                           
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed">
          
                    <a class="" href="/photos" title="Photos" >Photos</a>
                    
                              </li>

                                                                                                                                                                                  
                    
                    
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed toggle">
          
                    <a class="" href="/subscriptions-and-delivery" title="Subscriptions and Delivery" >Subscriptions and Delivery</a>
                    
                                <ul class="hidden dropit-submenu">
                          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/subscriptions-and-delivery/vacation-stop" title="Vacation Stop">Vacation Stop</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/subscriptions-and-delivery/delivery-problem" title="Delivery Problem">Delivery Problem</a>
                                  </li>
          
      
            
                        
                  
                  
              <li class="regular-subitem dropit-trigger submenu-collapsed">
      
                  <a href="/subscriptions-and-delivery/carrier-application" title="Carrier Application">Carrier Application</a>
                                  </li>
             
            </ul>
                    </li>

                                                                                        
                    
                              
                              
                              
                    
                                <li class=" dropit-trigger submenu-collapsed">
          
                    <a class="" href="http://www.mylocalflyers.ca/?locale=en&p=princegeorge" title="Flyers" target='_blank'>Flyers</a>
                    
                              </li>

                                                                                                                                                                                                        </ul>

       
      
    
    
        







  <ul class="d-flex flex-wrap flex-nav ">
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://classifieds.princegeorgecitizen.com/" title="Classifieds"  target='_blank'>Classifieds</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://princegeorgecitizen.jobfind.findem.ca/" title="Careers"  target='_blank'>Careers</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://classifieds.princegeorgecitizen.com/prince-george/transportation/search" title="Autos"  target='_blank'>Autos</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://classifieds.princegeorgecitizen.com/prince-george/real-estate-rentals/search" title="Rentals"  target='_blank'>Rentals</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://princegeorgecitizen.adperfect.com/" title="Submit An Ad"  target='_blank'>Submit An Ad</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://www.legacy.com/obituaries/princegeorgecitizen/" title="Obituaries"  target='_blank'>Obituaries</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="https://issuu.com/pgcitizen/docs/rew " title="Real Estate Weekly"  target='_blank'>Real Estate Weekly</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="https://issuu.com/pgcitizen/docs" title="Special Sections"  target='_blank'>Special Sections</a>
            </li>
      </ul>



      
    
    
        







  <ul class="d-flex flex-wrap flex-nav ">
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://princegeorgecitizen.pressreader.com/the-prince-george-citizen" title="Digital Edition"  target='_blank'>Digital Edition</a>
            </li>
      </ul>



      
  
        </div>


  
</section>

<section class="breadcrumb container-fluid">
    <div class="container">
      
                  
    
  
    
  
    
    
        	







   
      
    
    
        







  <ul class="d-flex flex-wrap flex-nav ">
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://classifieds.princegeorgecitizen.com/" title="Classifieds"  target='_blank'>Classifieds</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://princegeorgecitizen.jobfind.findem.ca/" title="Careers"  target='_blank'>Careers</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://classifieds.princegeorgecitizen.com/prince-george/transportation/search" title="Autos"  target='_blank'>Autos</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://classifieds.princegeorgecitizen.com/prince-george/real-estate-rentals/search" title="Rentals"  target='_blank'>Rentals</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://princegeorgecitizen.adperfect.com/" title="Submit An Ad"  target='_blank'>Submit An Ad</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://www.legacy.com/obituaries/princegeorgecitizen/" title="Obituaries"  target='_blank'>Obituaries</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="https://issuu.com/pgcitizen/docs/rew " title="Real Estate Weekly"  target='_blank'>Real Estate Weekly</a>
            </li>
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="https://issuu.com/pgcitizen/docs" title="Special Sections"  target='_blank'>Special Sections</a>
            </li>
      </ul>



      
    
    
        







  <ul class="d-flex flex-wrap flex-nav ">
    
                  
                      
                    <li class=" dropit-trigger submenu-collapsed">
      
              <a class="" href="http://princegeorgecitizen.pressreader.com/the-prince-george-citizen" title="Digital Edition"  target='_blank'>Digital Edition</a>
            </li>
      </ul>



      
  
          </div>
</section>
        
<section id="adTopLeaderboard" class="leaderboard-v2 text-center">
   <div id="leaderboardContent" class="content-ad-container">
     <div class="content-ad">
            
            
                              <div id='googlead-3to1_S1' class='adunit-gpt' style='min-height:1px;'></div>
        <div id='googlead-3to1_S1-oop' class='adunit-gpt' style='min-height:1px;'></div>
                  </div>
                      
          </div>
</section>

  
                  
    
  
    
  
    
    
        




      
  
         
<section role="main" class="container-fluid gmg-wrapper mt-2 pt-3">
<!-- Main Section Begin  -->

<div role="main-row" class="row">
<!-- Main Row Begin  -->
   <div class="span8 main-content col MC Hammer px-0">
<!-- Main content Begin (U Cant Touch This)-->
  



        



          
 		                 	 
    

  

<div class="fb-quotable span8 main-content story-level-page standard-article ">
<section class="story-carousel container-fluid px-0 single ">
<header class="">
		<span class="blogBadge "></span>
	<div class="fb-quote" data-href=""></div> <h1 class="headline pt-0 pb-2 my-0 font-weight-bold" itemprop="headline">Texans beat Titans 34-17 for team-record 8th straight win</h1>
<h4 id="pressboard-ad-sponsorship-tag" class="no-vert-padding"></h4>
</header>
<div class=" author-date-social container-fluid pl-0">
<div class="row no-gutters">
<div class="ancillary col-md-12 col-lg-6">
		 	 	 	 	 <span itemprop="author" itemscope itemtype="https://schema.org/Person">Kristie Rieken</span>
	 <span> / </span>	<span>The Associated Press</span><p class="p-published-time text-uppercase mt-1">November 26, 2018 08:33 PM</p>
</div> <div class="social-toolbar col-md-12 col-lg-6">
<ul class="no-list text-left text-lg-right mt-3 mt-lg-0">
	<li><span data-network="facebook" class='st_facebook_custom social-art st-custom-button' title="Share on Facebook" onclick="sendStatistic('/2.3463/2.3517', '1.23510412')"></span></li>
	<li><span data-network="twitter" class='st_twitter_custom social-art st-custom-button' title="Share on Twitter" onclick="sendStatistic('/2.3463/2.3517', '1.23510412')"  st_via="pgcitizen"></span></li>
	<li><span data-network="sharethis" class='st_sharethis_custom social-art st-custom-button' title="Share on Share This" onclick="sendStatistic('/2.3463/2.3517', '1.23510412')"></span></li>
	<li><span class="email_custom social-art" title="Email Article"><a href="javascript:void(0);" id="#emailArticleLink23510412" name="modal" data-toggle="modal" data-target="#emailArticle23510412">&#xf199;</a></span><li>
	<li><span class="print_custom social-art" title="Print Article"><a href="javascript:window.print()">&#xf02f;</a></span></li>
</ul>
</div> </div> </div><div class="rotator-images-wrapper">
 <div class="carousel slide" id="standardArticleCarousel">
  <div class="carousel-inner" role="listbox">       
            <div class="carousel-item active">
    <div class="image-container text-center">
    			<img title='Houston Texans running back Lamar Miller (26) runs past Tennessee Titans outside linebacker Brian Orakpo (98) during the first half of an NFL football game, Monday, Nov. 26, 2018, in Houston. (AP Photo/David J. Phillip)' height='auto' alt='TXEG118-1127_2018_003553.jpg' width='auto' class='d-inline-block img-fluid' src='https://images.glaciermedia.ca/polopoly_fs/1.23510428.1543302619!/fileImage/httpImage/image.jpg_gen/derivatives/landscape_804/txeg118-1127-2018-003553-jpg.jpg' />    <div class="carousel-caption mb-2 pr-3">
	    	    <div>Houston Texans running back Lamar Miller (26) runs past Tennessee Titans outside linebacker Brian Orakpo (98) during the first half of an NFL football game, Monday, Nov. 26, 2018, in Houston. (AP Photo/David J. Phillip)</div>
	    	    	   
    </div>
   </div>   </div>       </div>      </div> </div>   
		  
</section>

<!-- Story Level Carousel Element -->
<!-- Inline Video Content -->
    <!-- End Inline Video Content -->    
<div class="story-content">
 <div class="top-video-inline"></div>
 
                  
    
  
    
  
  
         <div class="parsedBody" itemprop="articleBody">
 <p>HOUSTON — The Houston Texans wanted to honour their late owner and founder Robert "Bob" McNair, who died last week at age 81.</p>
<p>They knew the perfect way to do that Monday night was to keep their winning streak going.</p>
<div class="article-continues text-center hidden-sm-up my-3 font-weight-bold">
 <i class="fa fa-angle-double-down mr-1" aria-hidden="true"></i>
 <div class="d-inline-block">
  article continues below
 </div>
 <i class="fa fa-angle-double-down ml-1" aria-hidden="true"></i>
</div>
<div id="adBoxWithLinksContainer" class="container-fluid my-4">
 <div class="row">
  <div class="col-md-12 col-lg-6 adColumn pl-0">
   <div id="googlead-1to1_S1" class="adunit-gpt" style="min-height:1px;"></div>
  </div>
  <div class="col-md-12 col-lg-5 linksColumn">
   <div id="articleAdLinksContainer">
    <h3 class="no-roof text-uppercase font-weight-bold">Trending Stories</h3>
    <ul class="article-adlinks-items no-list">
     <li class="article-adlinks-item"><a href="#">Shots heard, rifle found near trail</a></li>
     <li class="article-adlinks-item"><a href="#">Court docket: November 19-23, 2018</a></li>
     <li class="article-adlinks-item"><a href="#">RCMP spokesman during Dziekanski case had 'rage in his head,' widow says</a></li>
     <li class="article-adlinks-item"><a href="#">Prominent local volunteer mourned</a></li>
    </ul>
   </div>
  </div>
 </div>
</div>
<div id="relatedElementsMarker"></div>
<p>Deshaun Watson threw two touchdown passes and ran for another score as the Texans set a franchise record with their eighth straight victory, 34-17 over the Tennessee Titans.</p>
<p>"The one thing Mr. McNair wanted was a winner," J.J. Watt said. "All he wanted was a winner. He wanted to win every week. He wanted a team that could win and bring a championship to this city. So to be able to win eight straight and to be able to win tonight for him was good, and we're going to try to keep doing that for him."</p>
<div id="videoAdMarker" class="videoAdMarker" style="min-height:1px;line-height:1px;display:none;"></div>
<p>Demaryius Thomas scored his first two touchdowns with Houston and Lamar Miller ran for 162 yards, including a 97-yard TD.</p>
<p>The Texans (8-3) also saluted McNair by wearing decals in the shape of a football with white block letters bearing his initials of "RCM." With that tribute on the back of their helmets, they became the first team in NFL history to win eight games in a row after starting 0-3. They lead the AFC South by two games over Indianapolis.</p>
<p>"We need to try and keep getting better," coach Bill O'Brien said. "We need to take the mantra that we're going to improve every day."</p>
<p>The Texans trailed by 10 early before reeling off 27 straight points.</p>
<p>Houston receiver DeAndre Hopkins said there was no panic after the team fell behind in the first quarter.</p>
<p>"We've been down 0-3 as a record, so being down 10-0 on the board is nothing to this team," he said.</p>
<p>Tennessee (5-6) finally scored again on a 48-yard reception by Corey Davis late in the third quarter, but the second TD by Thomas — this one for 10 yards — made it 34-17 with just more than eight minutes left.</p>
<p>Marcus Mariota, who missed the second half of last week's game with a stinger, was 22 of 23 for 303 yards and two touchdowns. He completed his first 19 passes before an incompletion with just more than a minute remaining.</p>
<p>Miller's 97-yard breakaway in the second quarter made it 21-10. It was the longest run in franchise history and the longest in the NFL since his dash of the same length for a touchdown on Dec. 28, 2014, with the Dolphins. He's the only player in league history with two career rushing touchdowns of 95 yards or longer.</p>
<p>The Titans went ahead 3-0 on their first possession, and Jonnu Smith had a career-long 61-yard catch-and-run touchdown that extended their lead less than halfway through the first quarter.</p>
<p>Houston got going after that, cutting the lead to 10-7 when Thomas grabbed his first touchdown since being traded from Denver on Oct. 30, a 12-yard grab with about six minutes left in the quarter.</p>
<p>Watson put the Texans on top when he scrambled 15 yards for a score on the first play of the second quarter.</p>
<p>The Titans went for it on fourth-and-inches from the 3 later in the second, but tight end Luke Stocker was stopped for no gain.</p>
<p>"If you look at their goal-line defence and having a lot of good knowledge of what they do on the goal line, that's one play that had worked," Tennessee coach Mike Vrabel said. "It didn't work tonight and that's not the reason that we lost. That's a bad play."</p>
<p>Miller's long TD , which helped Houston set a franchise record with 281 yards rushing, came on the next play. He took the handoff in the end zone and darted through a crowd of Titans before shedding one tackle and simply outrunning the rest of the defence.</p>
<p>"My whole mindset is just, don't get caught," Miller said. "Because ... when we played the Dolphins, I got caught, so all the guys were giving me a hard time. So that was the only thing on my mind."</p>
<p>The Texans kicked a field goal as time expired in the second quarter to take a 24-10 lead into halftime.</p>
<p>MCNAIR REMEMBERED</p>
<p>The Texans honoured McNair in a pregame ceremony, which included a video tribute to him while the Texas A&amp;M Singing Cadets sang "Amazing Grace." While the video was played, one side of the video board displayed the words: "Faith, Family, Philanthropy, Football."</p>
<p>Painted on both 25-yard lines was a football with his initials that looked just like the decals on the players' helmets.</p>
<p>Television cameras panned to several fans with signs honouring the late owner. One read: "McNair Never Forgotten."</p>
<p>WATSON'S WORK</p>
<p>Watson has thrown 39 touchdown passes in his first 18 career games, which is third in NFL history behind Hall of Famers Kurt Warner (44) and Dan Marino (40). His 70 yards rushing on Monday were a career best and he tied Matt Schaub's franchise record by throwing a TD pass in his 16th straight game.</p>
<p>INJURIES</p>
<p>Titans cornerback Malcolm Butler left in the second quarter to be evaluated for a concussion and did not return. ... Houston WR Keke Coutee didn't return after injuring his hamstring in the third quarter.</p>
<p>UP NEXT</p>
<p>Titans: Host the New York Jets on Sunday.</p>
<p>Texans: Host the Cleveland Browns on Sunday.</p>
<p>___</p>
<p>More AP NFL: https://apnews.com/tag/NFL and https://twitter.com/AP_NFL</p>
<div id="footerContentPluginsContainer">
 <div id="pressboard-ad-sponsorship-msg"></div>
</div>
<div id="inlineVideoBottom"></div>
<div id="articleAppendages"></div>
<div id="klangooRelatedTopics" class="container-fluid px-0 mt-3">
 <div class="row py-2">
  <div class="col-12 col-lg-4">
   <h3 class="relatedTopicsTitle my-1">Read Related Topics</h3>
  </div>
  <div class="relatedTopicsContent col-12 col-lg-8 text-left text-lg-right my-3 my-lg-0">
   <div data-widget-id="ent_181-1"></div>
  </div>
 </div>
</div>
<div id="adBoxWithKlangooContainer" class="container-fluid pb-4 pb-lg-4">
 <div class="row justify-content-between">
  <div class="col-md-12 col-lg-5 col-xl-6 mt-4 mt-lg-3 p-0 klangooColumn ">
   <div data-widget-id="rel_181-1" class="klangooContent "></div>
  </div>
  <div class="col-md-12 col-lg-6 col-xl-5 mt-lg-5 mt-4 ad2Column">
   <div id="googlead-1to1_S2" class="adunit-gpt" style="min-height:1px;"></div>
  </div>
 </div>
</div>
</div>
<script>
  	var relatedUrl = "/news/local-news/shots-heard-rifle-found-near-trail-1.23509729";
	var relatedLinkClass = "relatedlink-processed";
	if (relatedUrl && relatedUrl.indexOf('cmlink') !== -1) {
		var relatedUrlFrags = relatedUrl.split('/');
		relatedUrl = './' + relatedUrlFrags[(relatedUrlFrags.length) -1];
		relatedLinkClass = "relatedlink-cmlink-processed";
	}
	jQuery("#articleAdLinksContainer ul > li").eq(0).children("a").attr("href",relatedUrl).addClass(relatedLinkClass);
  	var relatedUrl = "/news/local-news/court-docket-november-19-23-2018-1.23507606";
	var relatedLinkClass = "relatedlink-processed";
	if (relatedUrl && relatedUrl.indexOf('cmlink') !== -1) {
		var relatedUrlFrags = relatedUrl.split('/');
		relatedUrl = './' + relatedUrlFrags[(relatedUrlFrags.length) -1];
		relatedLinkClass = "relatedlink-cmlink-processed";
	}
	jQuery("#articleAdLinksContainer ul > li").eq(1).children("a").attr("href",relatedUrl).addClass(relatedLinkClass);
  	var relatedUrl = "/cmlink/gmg-glacier-media-group/canadian-press/news/national/rcmp-spokesman-during-dziekanski-case-had-rage-in-his-head-widow-says-1.23509354";
	var relatedLinkClass = "relatedlink-processed";
	if (relatedUrl && relatedUrl.indexOf('cmlink') !== -1) {
		var relatedUrlFrags = relatedUrl.split('/');
		relatedUrl = './' + relatedUrlFrags[(relatedUrlFrags.length) -1];
		relatedLinkClass = "relatedlink-cmlink-processed";
	}
	jQuery("#articleAdLinksContainer ul > li").eq(2).children("a").attr("href",relatedUrl).addClass(relatedLinkClass);
  	var relatedUrl = "/news/local-news/prominent-local-volunteer-mourned-1.23508405";
	var relatedLinkClass = "relatedlink-processed";
	if (relatedUrl && relatedUrl.indexOf('cmlink') !== -1) {
		var relatedUrlFrags = relatedUrl.split('/');
		relatedUrl = './' + relatedUrlFrags[(relatedUrlFrags.length) -1];
		relatedLinkClass = "relatedlink-cmlink-processed";
	}
	jQuery("#articleAdLinksContainer ul > li").eq(3).children("a").attr("href",relatedUrl).addClass(relatedLinkClass);
  </script>	

<div id="pageElements">

                  
    
  
    
  
  
      </div>
<div id="articleAppendageContent" class="mt-4 mb-3">
<!-- Begin: copyright, site specific labels, link back  -->

       <div class="article_copyright my-2">© Copyright 2018 Prince George Citizen</div>


<!-- End: copyright, site specific labels, link back  -->
</div>
</div>  <!-- story-content // -->     
    <div class="promo-content my-2">
        <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script> 

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
    </div>
<div id="relatedStoryContainer"></div>
<meta itemprop="datePublished" content="2018-11-26T20:33Z"/>
 <meta itemprop="dateModified" content="2018-11-26T23:10Z"/>
</div> <script type="text/javascript">
  // Story carousel init
  var saCarousel = jQuery('#standardArticleCarousel').carousel({
    interval: false
  });
//  jQuery('#standardArticleCarousel').carousel('pause');
</script>
<script type="text/javascript">

document.getElementById('articleAppendages').appendChild(document.getElementById('articleAppendageContent'));

jQuery().ready(function(){

	if (gmgObj.queuestep.hasQueuestep) {
    gmgObj.queuestep.initQueuestep();
	}
jQuery("#container .story-level-page .span5>.social").on("mouseover",function(){
    fixFBLikeOverflow();
    jQuery("#container .story-level-page .span5>.social").off("mouseover");
	});
});

var fixFBLikeOverflow = function() {
    jQuery("#container .story-level-page .span5>.social").css({overflow:"initial"});
};
if (window.addEventListener) // W3C standard
{
  window.addEventListener('load', fixFBLikeOverflow, false); // NB **not** 'onload'
} 
else if (window.attachEvent) // Microsoft
{
  window.attachEvent('onload', fixFBLikeOverflow);
    }
</script>
 

                 
<section id="emailArticle23510412" class="modal fade" role="dialog" style="display:none" aria-hidden="true">
<div class="modal-dialog" role="document">
<div class="modal-content">
<div class="modal-body">
<div id="emailArticleContainer" class="window container-fluid">
<div class="row">
    <div class="col">

  	<img src="/gmg/img/logos/PGCLogo.png" alt="Prince George Citizen" />
      </div>
	<div class="col-1">  
	  <button type="button" class="close" data-dismiss="modal" aria-label="Close">
			<span aria-hidden="true">×</span>
	  </button>
	</div> 
</div>  
  <div class="row mb-2 pb-2">
   <div class="col">
  	<h3 class="emailFriendTitle my-2 font-weight-bold">Email this article to a Friend</h3>
  	<div class="line">&nbsp;</div>
  	<div id="emailArticleError23510412" class="emailArticleError py-2" style="display:none"></div>
   </div>
  </div>        
                
    <form action="/spamcatch" id="emailArticleForm23510412" class="row pb-3 mb-3" onSubmit="sendStatistic('/2.3463/2.3517', '1.23510412')">
      <div class="col-6">
        <label class="mb-1" for="fromEmailAddr23510412">Your Email Address: *</label>
        <input type="text" class="mb-2" name="fromEmailAddr23510412" id="fromEmailAddr23510412" />
        <label class="mb-1" for="senderName23510412">Your Name: *</label>
        <input type="text" class="mb-2" name="senderName23510412" id="senderName23510412" />
        <label class="mb-1" for="toEmailAddr23510412">To Email Address: *</label>
        <input type="text" class="mb-2" name="toEmailAddr23510412" id="toEmailAddr23510412" />
        <div class="sub-msg">* Please separate multiple email addresses with the semi-colon character.</div>
      </div>
 	  <div class="col-6">
        <label class="mb-1" for="message23510412">Message: *</label>
        <textarea class="mb-3" rows="5" name="message23510412" id="message23510412"></textarea>
        <div class="sub-msg mb-2"><label id="emailCharacters" class="charLimit"></label></div>      
        <input type="submit" id="submitEmail23510412" value="Send Article" class="uibutton" />
      </div>
      <div class="line pt-3">&nbsp;</div>
    </form>
  
</div>  </div> </div> </div> </section>
<script>

  jQuery().ready(function() {
	      initEmailArticleForm23510412(); 
  });
    
  jQuery('#emailArticle23510412').on('show.bs.modal',function(e){
		resetEmailArticleForm('23510412');
  });

  function initEmailArticleForm23510412() {
    var validation = {
      rules: {
        fromEmailAddr23510412: {
            required: true,
            email: true
        },
        toEmailAddr23510412: {
            required: true,
            multiemail: true
        },
        senderName23510412: {
            required: true
        },
        message23510412: {
            required: true
        }
      },
      messages: {
        fromEmailAddr23510412: {
            required: "Sender email is required",
            email: "A valid email is required"
        },
        toEmailAddr23510412: {
            required: "Receiver email is required",
            multiemail: "A valid email is required"
        },
        senderName23510412: {
            required: "Sender name is required"
        },
        message23510412: {
            required: "Email message is required",
            email: "Email message is required"
        }
      },
      submitHandler: function(form) {
          var siteId = '2.3517';
		  var pageId = '2.3517';
          var articleId = '1.23510412';
		  
          emailArticle('23510412', siteId, articleId, pageId);
      }
    };
    var validator = jQuery("#emailArticleForm23510412").validate(validation);
  }
  
  function resetEmailArticleForm(elementId) {
    jQuery("#emailCharacters").html('');
    jQuery('#fromEmailAddr' + elementId).val('');
    jQuery('#senderName' + elementId).val('');
    jQuery('#toEmailAddr' + elementId).val('');
    jQuery('#message' + elementId).val('');
    jQuery('div.emailFriend').each(function(){
      jQuery(this).find('.error').remove();
    });
    jQuery('#submitEmail' + elementId).removeAttr("disabled");
    jQuery('#emailArticleError' + elementId).html('');
    
    // Reset individual errors
    jQuery("#emailArticleForm23510412 input.error, #emailArticleForm23510412 textarea.error").removeClass("error");
    jQuery("#emailArticleForm23510412 .error").remove();
    
    characterCounter(elementId);
  }
  
  function emailArticle(elementId, siteId, articleId, pageId) {
    var fromEmailAddr = jQuery('#fromEmailAddr' + elementId).val();
    var senderName = jQuery('#senderName' + elementId).val();
    var toEmailAddr = jQuery('#toEmailAddr' + elementId).val();
    var message = jQuery('#message' + elementId).val(); 
    var scrubbedMessage = message.replace(/(<([^>]+)>)/ig,"");
    
    if(articleId != '' && fromEmailAddr != '' && senderName != '' && toEmailAddr != '' && scrubbedMessage != '' && siteId != '') {
      jQuery.ajax({
        type: 'POST',
        dataType: 'json',
        url: '/emailarticle?articleId=' + articleId + '&fromEmailAddr=' + fromEmailAddr + 
        '&senderName=' + senderName + '&toEmailAddr=' + toEmailAddr + '&message=' + scrubbedMessage + '&siteId=' + siteId + '&pageId=' + pageId,
        success: function(response) {
          if (response.error) {
            jQuery('#emailArticleError' + elementId).html(response.error).show();
            
          } else {
 			  jQuery('#emailArticle23510412').modal('hide');
          }

        }
      });
    } else {

    }
  }

  function characterCounter(elementId)  {
    var charLimit = 200;
    
    jQuery("#emailCharacters").append("<strong>"+ charLimit +"</strong> characters remaining");
    
    jQuery("#message" + elementId).keyup(function(){
        if(jQuery(this).val().length > charLimit){
            jQuery(this).val(jQuery(this).val().substr(0, charLimit));
        }
        
        var remainingChars = charLimit -  jQuery(this).val().length;
    
        jQuery("#emailCharacters").html("<strong>"+ remainingChars + "</strong> characters remaining");
    
        if(remainingChars <= 20) {
            jQuery("#emailCharacters").css("color","#C11B17");
        }
        else {
            jQuery("#emailCharacters").css("color","#666");
        }
    });
  }
  

  jQuery.validator.addMethod("multiemail", function(value, element) {
	if(this.optional(element)) // return true on optional element
      return true;
        
    var emails = value.split(';');
    valid = true;
      
    for(var index in emails) {
      value = emails[index].replace(/(^\s+|\s+$)/g,"");
      valid = valid && jQuery.validator.methods.email.call(this, value, element);
    }
          
    return valid;
  }, 'The format for one or more emails is incorrect.');

</script><div id="sendStatHolder"></div>
  
         
        
	
<section class="" id="prevNextQueueHiddenContainer" style="display:none;">
    <div class="queuestep-nav">
      <div class="row article-row clearfix">
       <div class="col p-0 d-flex justify-content-start">
        <article class="previous step d-inline-block clearfix noIcon revealed">
                  </article>
       </div>        <div class="col p-0 d-flex justify-content-end">
        <article class="next step d-inline-block clearfix icon ">
                  
            <div class="nextQueueLinks queueLinks prev-next-col d-flex">
                <div class="direction align-self-start">
                    <a href="/news/local-news/city-prepared-to-face-the-snow-1.23510152">
                        <div class="prevNextQueueTitle text-right">next</div>
                        <div class="article-title text-right">City prepared to face the snow</div>
                    </a>
                </div>
            </div>
                          <div class="nextQueueImage image-wrapper prev-next-col">
                <a href="/news/local-news/city-prepared-to-face-the-snow-1.23510152">
                  <img title='With winter weather on its way, roads and fleet manager Blake McIntosh gives an update on city snow and ice control activities on Monday.' height='58' alt='snow-control.27_11262018.jpg' width='58' class='left m-0' src='https://images.glaciermedia.ca/polopoly_fs/1.23510153.1543277781!/fileImage/httpImage/image.jpg_gen/derivatives/box_58/snow-control-27-11262018-jpg.jpg' />                </a>
              </div>
                        <div class="nextQueueIndicator prev-next-col">
                <p class="indicator"><a href="/news/local-news/city-prepared-to-face-the-snow-1.23510152">&rsaquo;</a></p>
            </div>
          
          
                </article>
       </div>       </div>
    </div>
</section>


<section id="prevNextMobileQueueHiddenContainer" style="display:none;">
	<div class="queuestep-mobilenav container-fluid">
		<div class="row justify-content-between">
					<div class="col-6 py-2">&nbsp;</div>
							 <a class="d-block col-6 py-2 next-nav" href="/news/local-news/city-prepared-to-face-the-snow-1.23510152">
			  <div class="row">
				<div class="col next-headline pr-1">
					<div>City prepared to face the snow</div>
				</div>
				<div class="col-3 next-arrow text-right font-weight-bold">
					<div class="next-arrow-text text-uppercase">next</div>
					<div class="next-arrow-icon text-right fa fa-chevron-right"></div>
				</div>
			  </div>
			</a>
				</div>
	
	
	</div>
</section>

<!-- Main content End -->        
</div>

 <div class="col RC px-0 ml-3">
<!-- Rail Column Start   -->
<div id="googlead-1to2_S1" class="adunit-gpt text-center text-md-left" style="min-height:1px;"></div>
  

<section class="poll-element">
  <div class="tab-content">
        	<h2>The Next Prime Minister <b>POLL</b></h2>
    	<h4>With the federal election less than a year away, who would you like to see as prime minister?</h4>
    	<form method="post" action="/poll" id="poll_7_42690">
    	      		<fieldset>
                <legend style="display: none;"></legend>
                <input type="hidden" name="pollId" value="poll_7_42690" />
                <input type="hidden" name="questionId" value="0" />
                <input type="hidden" name="forward" value="/the-next-prime-minister-7.42690?ot=gmg.PopupPageLayout.ot" />

                                                                  <div class="form-check poll-vertical">
                  <input class="form-check-input" type="radio" value="0" name="answerId" id="poll_8198697_7_42690_answerId0">
				  <label class="form-check-label labelSection" for="poll_8198697_7_42690_answerId0">
				    <span class="labelSection"> Elizabeth May </span>
				  </label>
				  </div>
                                  <div class="form-check poll-vertical">
                  <input class="form-check-input" type="radio" value="1" name="answerId" id="poll_8198697_7_42690_answerId1">
				  <label class="form-check-label labelSection" for="poll_8198697_7_42690_answerId1">
				    <span class="labelSection">Andrew Scheer</span>
				  </label>
				  </div>
                                  <div class="form-check poll-vertical">
                  <input class="form-check-input" type="radio" value="2" name="answerId" id="poll_8198697_7_42690_answerId2">
				  <label class="form-check-label labelSection" for="poll_8198697_7_42690_answerId2">
				    <span class="labelSection">Jagmeet Singh</span>
				  </label>
				  </div>
                                  <div class="form-check poll-vertical">
                  <input class="form-check-input" type="radio" value="3" name="answerId" id="poll_8198697_7_42690_answerId3">
				  <label class="form-check-label labelSection" for="poll_8198697_7_42690_answerId3">
				    <span class="labelSection">Justin Trudeau </span>
				  </label>
				  </div>
                                <p class="centerBtn">
                <input type="submit" onclick="submitVote(this)" id="voteBtn" value="VOTE" class="voteSubmit" style="height:30px; width:80px" /> or 
                &nbsp;<a href="javascript:void(0)" onclick="window.focus(); return popupPollResultWindow('/the-next-prime-minister-7.42690?ot=gmg.PopupPageLayout.ot&amp;showResult=true');">view results</a>
                </p>
    		</fieldset>
    	  		      	</form>
        <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery("#poll_7_42690").attr("target", "pollResultWindow");
          });
        </script>
	  </div>
</section>

   <div id="emailSubscribeContainer" class="container-fluid py-2 my-3">
    <div id="mailchimp_email_signup" class="emailSignup">
        <section class="inner">
	        <div class="row mt-2 mb-3">
	            <div class="col font-weight-bold">Sign Up For Our e-Newsletter!</div>
            </div>
            <form class="emailSignup" id="rail_email_form">
            	<div class="row">   
	                <div class="text-center col">
	                	<input type="email" name="rrEmail" id="rrsEmail" placeholder="Enter your email" class="px-2 py-1" required>
	                </div>
	            </div>
	            <div class="row my-2 py-1">
	                <div class="col-6 subscribe-msg">Get the latest news right in your inbox.</div>
	                <div class="col-6 subscribe-button">
	                	<input type="submit" id="rrEmailSubscribe" value="Subscribe">
	                </div>
	            </div>
            </form>
        </section>
    </div>
</div><!-- End #emailSubscribeContainer -->

  
   
  <div class="tab-content stand-alone-teaser">
    <ul class="mt-3 ml-0">
    <li class="clearfix row">
          <div class="col-5">
        <p>
          <!-- TeaserElement renderLink #3 -->
		            <a href="http://issuu.com/pgcitizen/docs/citymatters" target="_blank" >
            <img title='City Matters icon' height='100' alt='City Matters icon' width='100' class='m-0' src='https://images.glaciermedia.ca/polopoly_fs/1.1943575.1432251345!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/city-matters-icon.jpg' />          </a>
        </p>
      </div>
          <div  class="col-6 p-0" >
        <h3 class="teaserElement mb-1 mt-0">
          <!-- TeaserElement renderLink #4 -->
          <a href="http://issuu.com/pgcitizen/docs/citymatters" target="_blank" >City Matters</a>
        </h3>
        <p class="te-txt">Your City Matters - City of Prince George</p>
      </div>
    </li>
    </ul>
  </div>
    

<section class="tab-view-element tab-element">
  <header>
    <h3 class="rail-category">Popular Citizen</h3>
  </header>
  <ul class="nav nav-tabs m-0" id="tab-view-element-tabs_7_10792_1511218447_8198700" role="tablist">
                                  <li class="nav-item list-unstyled"><a href="#tabs_7_10792_1511218447_8198700_tab1" data-toggle="tab" class="nav-link active" role="tab">You Might Like</a></li>
                            <li class="nav-item list-unstyled"><a href="#tabs_7_10792_1511218447_8198700_tab2" data-toggle="tab" class="nav-link " role="tab">Most Read</a></li>
                            <li class="nav-item list-unstyled"><a href="#tabs_7_10792_1511218447_8198700_tab3" data-toggle="tab" class="nav-link " role="tab">Most Recent</a></li>
      </ul>
                 
  <div class="tab-content most">
                      <div class="tab-pane active" id="tabs_7_10792_1511218447_8198700_tab1">
        <div data-widget-id="recom_181-8"></div>      </div>
                <div class="tab-pane" id="tabs_7_10792_1511218447_8198700_tab2">
        









                   
  <ul class='teaser'>
               
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/shots-heard-rifle-found-near-trail-1.23509729" >
          <img title='' height='100' alt='shots-fired.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23509730.1543258661!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/shots-fired-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/shots-heard-rifle-found-near-trail-1.23509729" >Shots heard, rifle found near trail</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/court-docket-november-19-23-2018-1.23507606" >
          <img title='' height='100' alt='court-docket.web_11232018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23507607.1542993940!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/court-docket-web-11232018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/court-docket-november-19-23-2018-1.23507606" >Court docket: November 19-23, 2018</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
              <div >
    <h3 class="tab-hl ">
	  <a href="/rcmp-spokesman-during-dziekanski-case-had-rage-in-his-head-widow-says-1.23509354" >RCMP spokesman during Dziekanski case had 'rage in his head,' widow says</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/prominent-local-volunteer-mourned-1.23508405" >
          <img title='Victor Bowman of Prince George, centre, receives an Award of Merit in 2011 from CDSBC president Dr. Bob Coles, left, and Registrar Heather MacKay, right.' height='100' alt='Victor-Frank-Bowman-obit.24.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23508406.1543039835!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/victor-frank-bowman-obit-24-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/prominent-local-volunteer-mourned-1.23508405" >Prominent local volunteer mourned</a><br>
    </h3>
    									<p class="le-published-time">November 23, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/the-weather-network-predicts-a-mixed-bag-of-winter-weather-for-canada-1.23509182" >
          <img title='A woman runs beside Lake Ontario as cold mist rises from the lake during a winter cold snap in Kingston, Ont. on Thursday, Nov. 22, 2018. Canadians can expect a "mixed bag" of winter weather in the coming months, according to The Weather Network. THE CANADIAN PRESS/Lars Hagberg' height='100' alt='CPT511515329.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23509184.1543235927!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/cpt511515329-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/the-weather-network-predicts-a-mixed-bag-of-winter-weather-for-canada-1.23509182" >The Weather Network predicts a "mixed bag" of winter weather for Canada</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/city-prepared-to-face-the-snow-1.23510152" >
          <img title='With winter weather on its way, roads and fleet manager Blake McIntosh gives an update on city snow and ice control activities on Monday.' height='100' alt='snow-control.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510153.1543277781!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/snow-control-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/city-prepared-to-face-the-snow-1.23510152" >City prepared to face the snow</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/holiday-magic-at-festival-of-trees-until-dec-2-1.23508555" >
          <img title='Callie, 6, on Mom Laura Harrop&#39;s knee, Ashlin, 10, Dad Brendan and Garrett, 8, have made attending the Festival of Trees the start of their holiday tradition for the last six years. ' height='100' alt='image.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23508583.1543096768!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/image-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/holiday-magic-at-festival-of-trees-until-dec-2-1.23508555" >Holiday magic at Festival of Trees until Dec. 2</a><br>
    </h3>
    									<p class="le-published-time">November 24, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/province-earmarks-10-million-for-indigenous-housing-project-1.23510200" >
          <img title='Aboriginal Housing Society of Prince George executive director Christos Vardacostas' height='100' alt='indigenous-housing.27_11262.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510201.1543280396!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/indigenous-housing-27-11262-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/province-earmarks-10-million-for-indigenous-housing-project-1.23510200" >Province earmarks $10 million for Indigenous housing project</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/more-changes-in-store-in-wake-of-cnc-student-s-death-1.23507171" >
          <img title='The chain link fence as it was being installed along Highway 97 in October to stop pedestrians from crossing the busy highway and instead use the controlled cross walk at 20th Avenue. ' height='100' alt='intersection-changes.23_112.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23507172.1542935714!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/intersection-changes-23-112-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/more-changes-in-store-in-wake-of-cnc-student-s-death-1.23507171" >More changes in store in wake of CNC student's death</a><br>
    </h3>
    									<p class="le-published-time">November 22, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/top-two-b-c-legislature-officials-deny-wrongdoing-want-to-go-back-to-work-1.23509862" >
          <img title='Sergeant-at-Arms Gary Lenz (L) and Clerk of the Legislative Assembly Craig James make a statement to media in Vancouver, B.C., on Monday November 26, 2018. THE CANADIAN PRESS/Ben Nelms' height='100' alt='VCRX108515480.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23509961.1543272128!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/vcrx108515480-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/top-two-b-c-legislature-officials-deny-wrongdoing-want-to-go-back-to-work-1.23509862" >Top two B.C. legislature officials  deny wrongdoing, want to go back to work</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
            </ul>
     
          
       </div>
                <div class="tab-pane" id="tabs_7_10792_1511218447_8198700_tab3">
        









                   
  <ul class='teaser'>
               
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/sports/ahac-anhorn-get-team-canada-west-invitations-1.23510468" >
          <img title='' height='100' alt='logo' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510469.1543301648!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/logo.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/sports/ahac-anhorn-get-team-canada-west-invitations-1.23510468" >Ahac, Anhorn get Team Canada West invitations</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/opinion/letters/boots-on-feet-first-1.23510461" >
          <img title='' height='100' alt='let-loughery.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510462.1543298549!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/let-loughery-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/opinion/letters/boots-on-feet-first-1.23510461" >Boots on feet, first</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/opinion/letters/hoping-for-a-third-no-1.23510458" >
          <img title='' height='100' alt='let-harder.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510459.1543298411!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/let-harder-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/opinion/letters/hoping-for-a-third-no-1.23510458" >Hoping for a third no </a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/opinion/letters/not-hog-wild-about-pr-1.23510454" >
          <img title='' height='100' alt='let-olsen.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510455.1543298336!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/let-olsen-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/opinion/letters/not-hog-wild-about-pr-1.23510454" >Not hog wild about PR</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/opinion/columnists/change-doesn-t-mean-better-1.23510449" >
          <img title='' height='100' alt='col-whitcombe.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510450.1543298071!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/col-whitcombe-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/opinion/columnists/change-doesn-t-mean-better-1.23510449" >Change doesn't mean better</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/sports/kings-move-closer-to-top-spot-in-bchl-1.23510431" >
          <img title='' height='100' alt='logo' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510435.1543297961!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/logo.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/sports/kings-move-closer-to-top-spot-in-bchl-1.23510431" >Kings move closer to top spot in BCHL</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/opinion/editorial/overstepping-his-bounds-1.23510432" >
          <img title='' height='100' alt='guestedit.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510433.1543297930!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/guestedit-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/opinion/editorial/overstepping-his-bounds-1.23510432" >Overstepping his bounds</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/entertainment/local-a-e/rising-star-opening-for-hicks-1.23510429" >
          <img title='' height='100' alt='andrew-hyatt.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510430.1543297160!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/andrew-hyatt-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/entertainment/local-a-e/rising-star-opening-for-hicks-1.23510429" >Rising star opening for Hicks</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/province-earmarks-10-million-for-indigenous-housing-project-1.23510200" >
          <img title='Aboriginal Housing Society of Prince George executive director Christos Vardacostas' height='100' alt='indigenous-housing.27_11262.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510201.1543280396!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/indigenous-housing-27-11262-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/province-earmarks-10-million-for-indigenous-housing-project-1.23510200" >Province earmarks $10 million for Indigenous housing project</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
                 
                  
              
                
                              
       
                           
                        
                   
        <li class="row  tab-li">
          <div class="col-5 p-0">
      <p>
  		<a href="/news/local-news/city-prepared-to-face-the-snow-1.23510152" >
          <img title='With winter weather on its way, roads and fleet manager Blake McIntosh gives an update on city snow and ice control activities on Monday.' height='100' alt='snow-control.27_11262018.jpg' width='100' class='left' src='https://images.glaciermedia.ca/polopoly_fs/1.23510153.1543277781!/fileImage/httpImage/image.jpg_gen/derivatives/box_100/snow-control-27-11262018-jpg.jpg' />                </a>
      </p>
    </div>  
        <div class='col-7 p-0'>
    <h3 class="tab-hl ">
	  <a href="/news/local-news/city-prepared-to-face-the-snow-1.23510152" >City prepared to face the snow</a><br>
    </h3>
    									<p class="le-published-time">November 26, 2018</p>
						  </div>
</li>
            </ul>
     
          
       </div>
      </div>
</section>    <section class="tab-view-element tab-element event-calendar">
  <header>
    <h2 class="helvetica-bold" style="font-size: 1.28571em; padding-left: 0.5em">Community Event Calendar</h2>
  </header>
<div class="tab-content">
<script type="text/javascript" src="//www.trumba.com/scripts/spuds.js"></script>
<script type="text/javascript">
	$Trumba.addSpud({
	webName: "prince-george-citizen",
	spudType : "datefinder" ,
	width: 140,
    height: 115,
	teaserBase : "/events" });
</script>
  <br/>
  <div class="helvetica-bold">
    <p style="padding: 0 1em;margin-bottom: 0;">Find out what's happening in your community and submit your own local events.</p>
  </div>
  <ul style="margin-top: 0;" class="list">
    <li>
      <h3>
        <a href="/entertainment/submit-event/">Add an event</a>
      </h3>
    </li>
    <li>
      <h3>
        <a href="/entertainment/events/">See all community events</a>
      </h3>
    </li>
  </ul>
</div>
</section>
    <style>
#pgcgas td {
    padding: 5px;
}
#pgcgas table {
    margin: 3px 0;
}
</style>
<!-- Start GasBuddy Code -->
<div id="pgcgas">
<table width="100%"><tr><td align="center" style="font-family:Arial; font-weight:bold; font-size:16px;">Lowest Gas Prices in<span id="tenlowest_title">&nbsp;Prince George</span></td></tr><tr><td align="center" id="gasbuddy_29189">
<script language="JavaScript" type="text/javascript" src="https://df.gasbuddy.com/feed.df?k=qm3BGDijraajVEeXaKJyF3NsLxE%2fDwZWpykyEAUdm%2fWRYvuh8Ex0I1SykFp3zfasLx6U4IjN1LUVW3QnJ%2fTWYg%3d%3d&i=29189"></script>
<!-- GasBuddy links are required by the terms of service. Removal may result in termination of service. Please contact GasBuddy support if you wish to make changes. -->
</td></tr><tr><td align="center" style="font-family:Arial; font-weight:bold; font-size:11px;"><b><a id="a_sitenm" href="http://www.BCGasPrices.com/Prince_George/index.aspx"target="_blank"><span id="site_lnk">Prince George Gas Prices</span></a>&nbsp;provided by <a href="http://www.GasBuddy.com" target="_blank">GasBuddy.com</a></b></td></tr></table>
</div>
<!-- End GasBuddy Code -->    <BR> <div id="googlead-300x150_S2" class="adunit-gpt" style="min-height:1px;"></div>
<!-- Rail Column End   -->         
</div>
	

<div id="emailSignupModalContainer" style="display:none;">
	<div id="email_signup_modal" class="emailSignup helvetica">	  
		<header>
			<img src="/gmg/img/logos/PGCLogo.png"/>
			<span class="super_hdr">Sign Up For Our Newsletter!</span>
	
</header>
<hr>

<section id="modalMain">  
	<span class="msg_hdr">
	Have the Prince George Citizen delivered to your inbox or your home each day - subscribe now! You can unsubscribe any time, or <a href="/contact-us" target="_blank">contact us</a> with any questions.
	</span>
	<img id="enewsLoading" style="visibility:hidden" src="/gmg/img/loading.gif">
	<form id="emailSignupForm" action="/mailchimpmulti?siteId=2.3517&action=subscribe" method="post" accept="html" accept-charset="utf-8">
        <input type="hidden" name="mcLists" id="mcLists">
        <fieldset>
            
            <input type="hidden" name="numNewsletters" value="1"/>
            	            <input type="hidden" name="lists" value="4d0889fc28">
			            
            
         
         </fieldset>
         <fieldset>
         	<label>
              <span>Your Email Address:*</span>
              <input class="popupEmail" type="email" name="email" required />
            </label>
         	<input type="submit" name="subscribe" class="uibutton" value="Subscribe">
         </fieldset>
      </form>
      
    <span id="modalErrorMsg" class="modalErrorMsg"></span>
</section>
<hr>	</div><!-- End #email_signup_modal -->
</div><!-- End #emailSignupModalContainer -->

<script>
var popupTimeout = 40000;
var displayPopup = false;
</script>
<!-- Main Row End  -->
</div>
<!-- Main Section End  -->
</section>

	            	<script>
 
jQuery('.featured-section-label > a').each(function(){
 
if (jQuery(this).text() == 'All sites news') {
jQuery(this).text('NEWS');
jQuery(this).attr('href','https://www.princegeorgecitizen/news');
} else if (jQuery(this).text() == 'LMP BC News') {
jQuery(this).text('NEWS');
jQuery(this).attr('href','https://www.princegeorgecitizen/news');
} else if (jQuery(this).text() == 'All sites opinion') {
jQuery(this).text('OPINION');
jQuery(this).attr('href','https://www.princegeorgecitizen/opinion');
} else if (jQuery(this).text() == 'LMP BC Opinion') {
jQuery(this).text('OPINION');
jQuery(this).attr('href','https://www.princegeorgecitizen/opinion');
}
 
});
 
</script>                	  	



<footer class="footer-main container mt-5">
    <a href="#" id="scroll" style="display: none;"><span class="fa fa-arrow-up $artTop"></span></a>
    <div class="row footer-main-row">
                                                    
      <div id ="footerCol1" class="image-logo-column px-1 my-3 my-lg-0 col-12 col-md-12 col-lg-2">
               <nav class="container">
          <div class="row inner">
        
          
            <ul class="no-list col">
                                          <li class="footer-logo">
                  <a href="/" 
                    title="PGC footer logo 2017"                    target="_blank">
                                  <img title='PGC footer logo 2017' height='34' alt='PGC footer logo 170px' width='170' class='mt-0 mb-2' src='https://images.glaciermedia.ca/polopoly_fs/1.23097959.1510954549!/fileImage/httpImage/image.jpg_gen/derivatives/original_size/pgc-footer-logo-170px.jpg' />                      </a>
                </li>
                              
                              </ul>
                                                                 </div>         </nav>
      </div>
                                
      <div id ="footerCol2" class="text-column px-1 my-3 my-lg-0 col-12 col-md-12 col-lg-4">
               <h4 class="mt-0 font-weight-bold">Glacier Papers</h4>
               <nav class="container">
          <div class="row inner">
        
          
            <ul class="no-list col">
                                          <li class="footer-logo">
                  <a href="http://www.alaskahighwaynews.ca/" 
                    title="Alaska Highway News"                    target="_blank">
                            Alaska Highway News
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.pipelinenewsnorth.ca/" 
                    title="Pipeline News North"                    target="_blank">
                            Pipeline News North
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.timescolonist.com" 
                    title="Times Colonist"                    target="_blank">
                            Times Colonist
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.burnabynow.com/" 
                    title="Burnaby Now"                    target="_blank">
                            Burnaby Now
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://tricitynews.com/" 
                    title="Tri-City News"                    target="_blank">
                            Tri-City News
                    </a>
                </li>
                              
                              </ul>
                                  <ul class="no-list col">
                                                                        <li class="footer-logo">
                  <a href="http://www.delta-optimist.com/" 
                    title="Delta-Optimist"                    target="_blank">
                            Delta-Optimist
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.newwestrecord.ca/" 
                    title="Royal City Record"                    target="_blank">
                            Royal City Record
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.nsnews.com/" 
                    title="North Shore News"                    target="_blank">
                            North Shore News
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.richmond-news.com" 
                    title="Richmond News"                    target="_blank">
                            Richmond News
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.vancourier.com" 
                    title="Vancouver Courier"                    target="_blank">
                            Vancouver Courier
                    </a>
                </li>
                              
                              </ul>
                                                                 </div>         </nav>
      </div>
                                
      <div id ="footerCol3" class="text-column px-1 my-3 my-lg-0 col-12 col-md-12 col-lg-4">
               <h4 class="mt-0 font-weight-bold">Other Sections</h4>
               <nav class="container">
          <div class="row inner">
        
          
            <ul class="no-list col">
                          				
        	    
                <li>
				  <a href="/about-us" 
                    title="About Us">
                            About Us
                    </a>
                </li>
                              
                                        				
        	    
                <li>
				  <a href="/advertising" 
                    title="Advertising">
                            Advertising
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://header.princegeorgecitizen.com/circulation" 
                    title="Subscriptions and Delivery"                    >
                            Subscriptions and Delivery
                    </a>
                </li>
                              
                                        				
        	    
                <li>
				  <a href="/contact-us" 
                    title="Contact Us">
                            Contact Us
                    </a>
                </li>
                              
                                        				
        	    
                <li>
				  <a href="/policies-terms-and-conditions" 
                    title="Policies, Terms and Conditions">
                            Policies, Terms and Conditions
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://pgcpics.smugmug.com/" 
                    title="PG Pics"                    target="_blank">
                            PG Pics
                    </a>
                </li>
                              
                              </ul>
                                  <ul class="no-list col">
                                                                        <li class="footer-logo">
                  <a href="http://thescenepg.com/" 
                    title="Scene"                    target="_blank">
                            Scene
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://prod-admin1.glacier.atex.cniweb.net:8080/fileserver/file/299370/filename/digital_nie.pdf" 
                    title="Newspapers in Education"                    target="_blank">
                            Newspapers in Education
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://issuu.com/pgcitizen/docs/rew" 
                    title="Real Estate Weekly"                    target="_blank">
                            Real Estate Weekly
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://issuu.com/pgcitizen/docs" 
                    title="Special Sections"                    target="_blank">
                            Special Sections
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="http://www.tvweekonline.ca/" 
                    title="TV Listings"                    target="_blank">
                            TV Listings
                    </a>
                </li>
                              
                              </ul>
                                                                 </div>         </nav>
      </div>
                                                
      <div id ="footerCol4" class="image-social-column px-1 my-3 my-lg-0 col-12 col-md-12 col-lg-2">
               <h4 class="mt-0 font-weight-bold">Connect</h4>
               <nav class="container">
          <div class="row inner">
        
          
            <ul class="no-list col">
                                          <li class="footer-logo">
                  <a href="https://www.facebook.com/pgcitizen" 
                    title="Facebook"                    target="_blank">
                            Facebook
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="https://twitter.com/pgcitizen" 
                    title="Twitter"                    target="_blank">
                            Twitter
                    </a>
                </li>
                              
                                                        <li class="footer-logo">
                  <a href="https://www.instagram.com/pgcitizennewspaper/" 
                    title="Instagram"                    target="_blank">
                            Instagram
                    </a>
                </li>
                              
                                        				
        	    
                <li>
				  <a href="/site-map" 
                    title="RSS">
                            RSS
                    </a>
                </li>
                              
                              </ul>
                                                                 </div>         </nav>
      </div>
       </div>
  <div class="row copyright">
	  <div class="col">
	  	<div class="copyright">© Copyright 2018 Glacier Community Media</div>
	  </div>
  </div>
    
  <!-- Footer Navigation Block ends -->     
</footer>
	      
<script>
	gmgObj.queuestep.hasQueuestep = true;
</script>
      
<div class="hidden">
  <img src='/logger/p.gif?a=1.23510412&amp;d=/2.3463/2.3517' alt='' />    </div>
</div>
<!-- #container div end -->
    
<script type="text/javascript">
                        var _sf_async_config = {};
    _sf_async_config.uid = 41412;
    _sf_async_config.domain = 'princegeorgecitizen.com';
    _sf_async_config.useCanonical=true;
      _sf_async_config.sections = 'homepage';
        _sf_async_config.authors = 'Kristie Rieken';
      (function() {
    	function loadChartbeat() { 
    		window._sf_endpt = (new Date()).getTime(); 
    		var e = document.createElement('script'); 
		e.setAttribute('language', 'javascript'); 
		e.setAttribute('type', 'text/javascript'); 
		e.setAttribute('src', (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "https://static.chartbeat.com/") + "js/chartbeat.js"); 
		document.body.appendChild(e);
	}
	var oldonload = document.ready;
	document.ready = (typeof document.ready != 'function') ? loadChartbeat() : function() { 
 //   		oldonload(); 
    		loadChartbeat(); 
    	};
    })();
  </script>
        
<div id="extAdContainer">
	<div id='googlead-wallpaper_S1' class='adunit-gpt' style='min-height:1px;'></div>
	<div id='googlead-wallpaper_S1-oop' class='adunit-gpt' style='min-height:1px;'></div>
    
</div>
<div id="gdprAdContainer">
	<div id='googlead-GDPR' class='adunit-gpt' style='min-height:1px;'></div>
	<div id='googlead-GDPR-oop' class='adunit-gpt' style='min-height:1px;'></div>
    
</div>

<script>
jQuery(document).ready(function(){
  jQuery('[data-toggle="tooltip"]').tooltip({
	delay: {show:100, hide: 1000}
	})
});

</script>
<script>
// Adblock detection
gmgObj.adblockDetect = {
	isAdblocking: false,
	debug: true,
	pushGTMEvent: function() {
		try {
			dataLayer.push({
		      'event': 'gmgAdblockerDetected'
		    });
		} catch(e) {
			console.log('@@@@ Adblocker detection GTM event push failed with message => '+e.message);
		}
	},
	showWarning: function() {
		var html = '<div id ="alertAdblockerDetected" class="alert alert-dark alert-dismissable">'+
            		'<button type="button" class="close" ' + 
                    'data-dismiss="alert" aria-hidden="true">' + 
                	'&times;' + 
            		'</button>' + 
            		'We noticed you have an ad blocker turned on. This website subscribes to IAB\'s LEAN advertising principles. ' + 
            		'Light, Encrypted, Ad choice supported, Non-invasive ads. Please support local Journalism and consider turning off ' + 
            		'your ad blocker while visiting.' + 
         			'</div>';
         jQuery('body').append(html);
		Cookies.set('gmgAdblockerWarning','sessionShown');
	}
};

if ( !(Cookies.get('gmgAdblockerChecked') && Cookies.get('gmgAdblockerChecked') == 'sessionChecked') ) {
		var myScript = document.createElement("script");
		var debug = gmgObj.adblockDetect.debug;
	    myScript.type = "text/javascript";
	    myScript.async = true;
	    myScript.src = '/gmg/v2/theme-news1/js/ads.js';
	    myScript.onload = function(){
	        if (debug) console.log("@@@@@ ads.js has loaded. No adblocker detected"); 
	    };
	    myScript.onerror = function() {
	    	if (debug) console.log("@@@@@ ads.js script didn't load. Adblocker detected");
	    	if (debug) console.log('@@@@@ pushing GTM adblocker found event for this session');
	    	gmgObj.adblockDetect.pushGTMEvent();
	    	if (!(Cookies.get('gmgAdblockerFound') && Cookies.get('gmgAdblockerFound') == 'set30')) {
	    		Cookies.set('gmgAdblockerFound','set30', { expires: 30 });
	    		if (debug) console.log('@@@@@ Setting gmgAdblockerFound cookie to set30');
	    		if ( !(Cookies.get('gmgAdblockerWarning') && Cookies.get('gmgAdblockerWarning') == 'sessionShown') ) {
	    			gmgObj.adblockDetect.showWarning();
	    		} else {
	    			if (debug) console.log('@@@@@ Adblocker warning already shown. Skipping ...');
	    		}
	    		
	    	} else {
	    		if (debug) console.log('@@@@@ gmgAdblockerFound cookie 30 already set');
	    	}
	    }
	    Cookies.set('gmgAdblockerChecked','sessionChecked');
	    document.body.appendChild(myScript);
} else {
	if (gmgObj.adblockDetect.debug) console.log('@@@@@ gmgAdblockerChecked has already executed for this session. Skipping ...')
}


</script>

<script>
  jQuery('.story-content a[href^="http"]').each(function(){
      (jQuery(this).attr("target") != undefined && jQuery(this).attr("target").length > 1 ) ? "" : jQuery(this).attr("target","_blank");
  });
</script>

<script type="text/javascript" >
	(function() { 
		var s = document.createElement('script'); 
		s.type = 'text/javascript';
		s.async = !0; 
		s.src = 'https://adserver.pressboard.ca/v1/embedder?media=130497'; 
		var d = document.getElementsByTagName("script")[0];
		d.parentNode.insertBefore(s, d); 
	})();
</script>
<!-- Klangoo Embed -->
<script src="//magnetapi.klangoo.com/w/Widgets_181.js" async=""></script>
 </body>
</html>